Android 3DS Update

Published: 9th June 2020

When the RingGo app next updates, it will include 3DS security protection for all payments. Your phone therefore needs to be running Android 6.0 Marshmallow operating system (or later) for you to continue to book parking sessions through the RingGo app.

We are committed to giving you the highest level of security and will soon be legally obliged by the Financial Conduct Authority (FCA) to make sure we have 3DS security protection in the app. The RingGo app upgrading to 3DS is also required to keep up our highest level of PCI security certification. By using 3DS, you will have even stronger protection from fraud and greater piece of mind when making an online purchase on your phone, not just in the RingGo app.

So, to be able to continue using the app, please update your operating system to make sure you can benefit from this extra layer of security when making payments on your phone.